Firebird News

Thursday, April 24, 2008

Eclipse subversion Problem: Javahl interface is not available. Check your environment.


so you need to install libsvn-dev and libsvn-java if you have problems in subclipse Window->Preferences->Team-> SVN and choose JavaHL(JNI)

$sudo apt-get install libsvn-dev
$sudo apt-get install libsvn-java




also an good ideea is to tweak the vmargs to include /usr/lib/jni

/opt/eclipse/eclipse -vmargs -Djava.library.path=/usr/lib/jni

or put in in eclipse.ini

here is another article with the same solution

5 comments:

TonyMaro said...

Short and to the point! Saved me a lot of time. Thanks!

TonyMaro said...

Oops - followed your directions and it didn't get rid of the error...

mariuz said...

sudo apt-get install libsvn-java

at least that is on my intrepid ibex

mariuz said...

also you need to tweak the vmargs
to include /usr/lib/jni

/opt/eclipse/eclipse -vmargs -Djava.library.path=/usr/lib/jni

mariuz said...

here is the vmargs tip

http://islandlinux.org/howto/installing-javahl-subclipse-eclipse-ubuntu-7-10