Firebird News

Monday, January 19, 2009

Installing qt4.5 with Firebird support
and running the db demo (tested on ubuntu jaunty but it should work on intrepid too)

I assume firebird2.1 installed also the devel related packages


I use the snapshot usually (I use the webkit for arora) but you can download an more stable package from qtsoftware

http://www.qtsoftware.com/developer/preview-qt-4.5

git clone --depth 1 git://labs.trolltech.com/qt-snapshot


export PATH="/usr/local/Trolltech/Qt-4.5.0/bin:$PATH"
cd qt-snapshot
git pull
ln -s /usr/lib/libfbclient.so.2.1.1 /usr/lib/libgds.so
./configure -no-accessibility -no-exceptions -no-qt3support -nomake examples -nomake demos -plugin-sql-ibase -v
make && sudo make install


i use qt-creator to open an demo for sql

http://mapopa.blogspot.com/2009/01/qt-creator-is-now-open-source-here-is.html


open the sqlbrowser.pro from

qt-snapshot/demos/sqlbrowser

Compile it and press run

driver QIBASE
then fill the db name with
/var/lib/firebird/2.1/data/employee.fdb
username:SYSDBA
password:********

I was inspired by this thread from ubuntu forums

http://ubuntuforums.org/showthread.php?p=6577210#post6577210

And here is the screenshot

10 comments:

GiAndrea said...

Hi

i've a problem installing Firebird plugin on QT4.4.3, can you help me?

After compiling, I can see this error:

/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool: internal link edit command failed
lipo: can't figure out the architecture type of: /var/tmp//ccZaueX0.out
make[1]: *** [../../../../plugins/sqldrivers/libqsqlibase_debug.dylib] Error 1
make: *** [debug-all] Error 2

mariuz said...

for me it looks like an libtool issue

http://www.google.com/search?q=lipo:+can't+figure+out+the+

mariuz said...

this the libtool google search

http://www.google.com/search?hl=en&client=Arora&q=libtool:+internal+link+edit+command+failed&btnG=Search

mariuz said...

I see you are on powerpc another question

firebird is installed for powerpc ?

GiAndrea said...

Thanks Mauriz,

firebird is installed for Universal (Intel x86, 32-bit Classic package, compressed). On

http://doc.trolltech.com/4.4/sql-driver.html

I've read that I need the InterBase/Firebird development headers and libraries to build this plugin but I don't know where I can found it (here http://www.ibphoenix.com/main.nfs?a=ibphoenix&page=ibp_development ?)

thanks!!!!

mariuz said...

usually it should be in the package already

could you tell what cpu do you have (powerpc or x86)
I see that for firebird 2.1.1 only the x86 or powerpc is released (no universal )

http://www.firebirdsql.org/index.php?op=files&id=engine_211

mariuz said...

can you show me the content of

/opt/interbase/include
/opt/interbase/lib

or search on the system for ibase.h

GiAndrea said...

The ibase.h file is in:

/Library/Frameworks/Firebird.framework

on Versions/Current/Headers
ib_util.h
ibase.h
iberror.h
perf.h


on Versions/Current/Libraries
libfbclient.dylib
libib_util.dylib
libicudata.dylib
libicui18n.dylib
libicuuc.dylib

mariuz said...

here are some tips for using on macosx (see the comments area there are some qt issues solved there)

http://paulbeachsblog.blogspot.com/2008/03/where-is-libfbclientdylib-on-macosx.html

also i have asked on firebird-support about this
http://tech.groups.yahoo.com/group/firebird-support/message/99834

GiAndrea said...

Fixed!

on Makefile.Release and Makefile.Debug there was -arch ppc and -arch i386 flags. I've removed -arch ppc