Firebird News

Monday, September 07, 2009

Firebird 2.1 dependency graph in ubuntu

I was reading about debian and ubuntu bloat growing , more useless packages are installed by default
Read the full article here

"For comparison, the size of a default Gnome desktop install for Etch was 1360MB; for Lenny it is 1830MB; for Squeeze it looks like it will be well over 3000MB! Remember that for Sarge we installed both Gnome and KDE from CD1 with both together taking 1390MB?"

So i wanted to create a dependecy graph for firebird using Debtree
http://alioth.debian.org/~fjp/debtree/

All you need is to install the debtree package , seems that is not included by default in ubuntu So click here
http://alioth.debian.org/~fjp/debtree/debtree_0.7.3_all.deb

$ debtree firebird2.1-super >out.dot
$ dot -T png -o out.png out.dot


No comments: