Firebird News

Saturday, January 31, 2009

installing apc on ubuntu

$apt-get install php5-dev
$wget http://pecl.php.net/get/APC-3.1.2.tgz
$tar -zxvf APC-3.1.2.tgz
$cd APC-3.1.2

$phpize
$./configure
$make
$sudo make install

cp apc.php /var/www

sudo vi /etc/php5/apache2/php.ini
add these lines
extension=apc.so

[apc]
apc.shm_size = 100
apc.cache_by_default = 1
apc.stat = 1

and restart the apache server

and load
http://localhost/apc.php

default username and password are apc and password
you can change them in /var/www/apc.php

sudo /etc/init.d/apache2 restart

Thursday, January 29, 2009

ubuntu intrepid upgrade on everex gpc3

seems that you need to enable the ubuntu official repositories and after the upgrade is made from hardy to intrepid you need to change the /boot/grub/menu.lst so that root=/dev/sda1
seems that you will have some issues with uuid if is not in the /etc/fstab
so is better to be added in grub too


Update:
I got an server cd from boston loco meeting so the os is reinstalled
I didn't needed the home partition to be so big reformated the drive anyway

After all finished i have removed the apparmour and other useless stuff that comes with server
also usually i like that server install is more clean (the list of processes)
The weird stuff : on the case there is an sticker with VIA C7
and that is an mistake , inside is an athlon64 core (sempron)
http://www.everexstore.com/everex/products/gpc3/gpc3.php

Monday, January 26, 2009

ubuntu jaunty issues on dell vostro

here is how you can make wireless work on dell vostro

https://help.ubuntu.com/community/WifiDocs/Driver/Atheros


you need to reboot after the madwifi is disbled

here is how the Hardware Driver should look

System -> Administration -> Hardware Drivers
And Support for Atheros Should be Disabled

Thursday, January 22, 2009

Grub voodoo error no 13/24 and how do i fixed it

It all started by an reboot then the error i saw was

24 : Attempt to access block outside partition
This error is returned if a linear block address is outside of the disk partition. This generally happens because of a corrupt filesystem on the disk or a bug in the code handling it in GRUB (it's a great debugging tool).

What i did next was to boot from an Jaunty jack live cd and i have checked the partition
with fsck -pf -v /dev/sda1
no errors

Next i chroot-ed and tried to reinstall the kernel 2.6.28 from ubuntu repository
$ sudo su
$ mount /dev/sda1 /mnt
$ mount --bind /dev /mnt/dev
$ mount --bind /dev/pts /mnt/dev/pts
$ mount --bind /dev/shm /mnt/dev/shm
$ mount -t proc none /mnt/proc
$ mount -t sysfs none /mnt/sys

and then dpkg -i

no result after booted i was greeted with error no 13

13 : Invalid or unsupported executable format
This error is returned if the kernel image being loaded is not recognized as Multiboot or one of the supported native formats (Linux zImage or bzImage, FreeBSD, or NetBSD).

So i did an grub recovery
$ grub
$ grub> root (hd0,0)
$ grub > setup (hd0)
$ grub > exit

rebooted and no change
so i have booted the livecd again and did the chroot from above
and then i did an grub install

$ sudo grub-install /dev/sda --root-directory=/ --recheck

and seems that it changed the device.map
from hda to sda

cat /boot/grub/device.map
(fd0) /dev/fd0
(hd0) /dev/sda

rebooted and all was ok after that

Wednesday, January 21, 2009

We have decided to kill the cable TV

it's dead end , We don't look at tv for about 2 weeks

Also the romanian tv stations are misserable
Mizerilion 2009 (also known as Parangelion 2009 )
Elodia is back
and there is no Music at MTV or other stations

Long long time ago I cut hbo contract (worthless movies and i don't like it anymore)

I use only the youTube and ignore the noise that is TV

Quote from LCA2009
He contrasted TV channels (you had to watch what they decided to screen) and YouTube where something like a number of hours of video was uploaded every minute.
President Barack Obama 2009 Inauguration and Address in OGV (free speech format)

http://tinyvid.tv/show/17unvmqqh0was


This site currently exists to test out usage of the HTML 5 video and audio elements with the Ogg codecs. You'll need a browser that can playback Ogg media Firefox 3.1 nightly builds, Opera experimental builds and Safari with XiphQT installed can playback videos with varying degrees of success. Support for non-HTML5 compatible browsers may follow to test fallback options.

ogv can contain hd format too

http://tinyvid.tv/show/ah2ebubqurvy

Digital Tipping Point: Clip of the Day


Lawyer John Koenig on how people make money with Free Software 09 (2004)



Ogg Theora





Digital Tipping Point is a Free software-like project where the raw videos are code. You can assist by participating.



This was an example for ogv (ogg/theora video) taken from this site
I just show how simple can be to support the theora streaming , also the encoding and transmitting is very simple with vlc or other solutions

Tuesday, January 20, 2009

dark magic acpi - animal sacrifice needed
 
whenever i see acpi my hair goes up 

QOD from linuxjournal:
I counted no less than 10 instances of the word 'magic' during his explanation of how ACPI suspend happens. After my misspent youth digging into making Linux go on laptops I fully believe him that magic is involved. Dark magic. Involving animal sacrifice. Possibly the animal operating the computer.
silverlight on jaunty 64 (moonlight phase)

I have installed the silverlight plugin for linux (moonlight)
http://tirania.org/blog/archive/2009/Jan-20.html

I have downloaded the 64 version from here
http://www.go-mono.com/moonlight/
Then installed it in abrowser 3.0.5

Restarted the browser and then some codecs were installed for watching movies
Tested on this page
http://www.silverlight.net/fox/

also i watched the starting for presidential change in usa
http://www.pic2009.org/page/content/linuxplayer




I feel a little impaired because only 1.0 is used and we (linux users and macosx ones)
we are treated like 3rd class citizens and we have to accept proprietary formats

This is the new digital semi ghetto created by new lobby (pro microsoft it seems)
I wonder why is not in ogv (theora video) format ...

Monday, January 19, 2009

nepomukservicestub error with new kde4.2 rc from jaunty

and seems that i can't submit the bug automatically

ext3 to ext4 migration on ubuntu jaunty jack ( upgrade from intrepid)

It might be possible to move the root and boot partition on intrepid
but there are many things that must be installed by hand (new kernel , new grub ...)
so the best way is to migrate to jaunty (kernel does have support and also the grub)
on my station i did in terminal (upgrade command to jaunty)

$ sudo update-manger -d

then i have downloaded an daily live cd for jaunty (an alpha 3 should work too)

http://cdimage.ubuntu.com/daily-live/current/

i booted the live cd and opened an console

$ sudo tune2fs -O extents,uninit_bg,dir_index /dev/sda1

$ sudo fsck -pf /dev/sda1




mount it

$ sudo mount -t ext4 /dev/sda1 /mnt
$ sudo pico /mnt/etc/fstab

and you see ext3 for the / partition , please change it to ext4



save it reboot and eject the cdrom and see if it works (boots)

the guide that i have used is located here
http://kernelnewbies.org/Ext4#head-3891522e0601162aab24c73c1f148a1e28c6a9d4
Installing qt4.5 with Firebird support
and running the db demo (tested on ubuntu jaunty but it should work on intrepid too)

I assume firebird2.1 installed also the devel related packages


I use the snapshot usually (I use the webkit for arora) but you can download an more stable package from qtsoftware

http://www.qtsoftware.com/developer/preview-qt-4.5

git clone --depth 1 git://labs.trolltech.com/qt-snapshot


export PATH="/usr/local/Trolltech/Qt-4.5.0/bin:$PATH"
cd qt-snapshot
git pull
ln -s /usr/lib/libfbclient.so.2.1.1 /usr/lib/libgds.so
./configure -no-accessibility -no-exceptions -no-qt3support -nomake examples -nomake demos -plugin-sql-ibase -v
make && sudo make install


i use qt-creator to open an demo for sql

http://mapopa.blogspot.com/2009/01/qt-creator-is-now-open-source-here-is.html


open the sqlbrowser.pro from

qt-snapshot/demos/sqlbrowser

Compile it and press run

driver QIBASE
then fill the db name with
/var/lib/firebird/2.1/data/employee.fdb
username:SYSDBA
password:********

I was inspired by this thread from ubuntu forums

http://ubuntuforums.org/showthread.php?p=6577210#post6577210

And here is the screenshot

Thursday, January 08, 2009

qt creator is now open source

here is how you can compile it from git

$ git clone git://labs.trolltech.com/qt-creator

I use qt snapshot for arora installed in /usr/local/

$ export PATH="/usr/local/Trolltech/Qt-4.5.0/bin:$PATH"

$ cd qt-creator/

$ /usr/local/Trolltech/Qt-4.5.0/bin/qmake

$ make
$./bin/qtcreator

and open an project , in my case arora , Happy debugging

Wednesday, January 07, 2009

merging an fork with the main repository in git

I have fork-ed arora and i had added some very small changes
the problem is to update my repository and merge the changes already done on the main one

I go to my local cloned repository (the forked one is in my github account)
I use fetch to check what is changed vs my repository


$ git fetch git://github.com/Arora/arora.git master

watch the log
$ git log -p HEAD..FETCH_HEAD

or with gitk

$ gitk HEAD..FETCH_HEAD

I have added an remote repositry (so we have less typing)

$git remote add icefox git://github.com/Arora/arora.git
$ git fetch icefox
From git://github.com/Arora/arora
 * [new branch]      master     -> icefox/master
$git merge icefox/master

Removed src/locale/pt_BR.ts
Merge made by recursive.
arora.pro | 2 +-
autotests/autotests.pro | 1 +
manualtests/manualtests.pro | 4 ++--
src/locale/locale.pri | 5 +++--
src/locale/pt_BR.ts | Bin 43813 -> 0 bytes
src/locale/sk_SK.ts | Bin 0 -> 63590 bytes
src/locale/zh_CN.ts | Bin 0 -> 62833 bytes
src/utils/lineedit.cpp | 39 ++++++++++++++++++++++++---------------
src/utils/lineedit.h | 39 ++++++++++++++++++++++++---------------
src/utils/lineedit_p.h | 39 ++++++++++++++++++++++++---------------
src/utils/proxystyle.h | 2 +-
src/webview.cpp | 2 ++
tools/tools.pro | 7 ++++++-
13 files changed, 88 insertions(+), 52 deletions(-)
delete mode 100644 src/locale/pt_BR.ts
create mode 100644 src/locale/sk_SK.ts
create mode 100644 src/locale/zh_CN.ts

Then i tried to push the changes in my forked repository

git push origin master
To git@github.com:mariuz/arora.git
! [rejected] master -> master (non-fast forward)
error: failed to push some refs to 'git@github.com:mariuz/arora.git'

seems that i have made some changes in the repository at github that i didn't got them down

$ git pull
remote: Counting objects: 8, done.
remote: Compressing objects: 100% (6/6), done.
remote: Total 6 (delta 4), reused 0 (delta 0)
Unpacking objects: 100% (6/6), done.
From git@github.com:mariuz/arora
94cffc2..5c00b4c master -> origin/master
Merge made by recursive.
build_arora_qt_snapshot.sh | 6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)

$ git push origin master
Counting objects: 73, done.
Compressing objects: 100% (54/54), done.
Writing objects: 100% (54/54), 22.46 KiB, done.
Total 54 (delta 39), reused 0 (delta 0)
To git@github.com:mariuz/arora.git
5c00b4c..cdb7bb3 master -> master

So here it is the merge was done

http://github.com/mariuz/arora/commits/master
installing openoffice 3.0 pdf import extension

To do this download the extension from http://extensions.services.openoffice.org/project/pdfimport. Save the file and from within OpenOffice 3.0 open Tools->Extensions manager. That will pop up a dialog box. Choose “Add” to load the PDF import extension.

Then open an pdf file like any other


ubuntu intrepid notes on sony vaio
I have tested intrepid on an vaio , an recent model with core2duo and geforce8600 (i don't remember de specs exactly)
All worked great (compiz, wireless ...) except when inserting the headphones (no sound in them)

so i had to add an line in
sudo nano /etc/modprobe.d/alsa-base

options snd-hda-intel model=vaio

(and then all was ok ) . I wonder why it wasn't detected