Firebird News

Sunday, May 09, 2010

Installing the latest ruby on rails on any ubuntu :lynx,karmic ....

I needed to have the latest rails on my ubuntu desktop : lucid lynx (the one that is by default in repository is too old)

and this command will not work on any debian based system because it's disabled and
it will break the debian way
sudo gem update --system
anyway you can update and the replace the gem installed on the system this way
sudo gem install rubygems-update
sudo update_rubygems

if it's not in the path (I wonder why is not there by default when the gem package is installed)
you can do this
sudo  /var/lib/gems/1.8/bin/update_rubygems 
RubyGems 1.3.6 installed

=== 1.3.6 / 2010-02-17
changelog and notices
--------------------------------

RubyGems installed the following executables:
 /usr/bin/gem1.8


then you can install the latest stable rails
sudo gem install rails

No comments: