Firebird News

Wednesday, July 20, 2011

kwaak3 compiling for android 2.x

check out the source code

svn checkout http://kwaak3.googlecode.com/svn/trunk/ kwaak3

install sdl headers
sudo apt-get install libsdl-1.2-dev

cd kwaak3
cd ioquake
I have setup the android-ndk dir

like this in Makefile.local

ANDROID_NDK_DIR=/opt/android-ndk-r5b/
CC=/opt/android-ndk-r5b/toolchains/arm-eabi-4.4.0/prebuilt/linux-x86/bin/arm-eabi-gcc-4.4.0

with ndk-r5 i get
Issue 140: can't compile ioquake: gl.h:719: error: expected '=', ',', ';', 'asm' or 'attribute' before 'glScissor'

with ndk6 i get

make[2]: Entering directory `/home/mariuz/work/kwaak3/ioquake3'
CC code/client/cl_cgame.c
gcc: error trying to exec 'cc1': execvp: No such file or directory
Assembler messages:
Fatal error: invalid -march= option: `armv5te'
make[2]: *** [build/release-linux-arm/client/cl_cgame.o] Error 1
make[2]: Leaving directory `/home/mariuz/work/kwaak3/ioquake3'
make[1]: *** [targets] Error 2
make[1]: Leaving directory `/home/mariuz/work/kwaak3/ioquake3'
make: *** [release] Error 2

1 comment:

olexandr said...

hi a have the same problem with NDK r8. anybody knows where is the problem?