Firebird News

Wednesday, September 16, 2009

Compiling #mysql #workbench alpha 5.2.x on #ubuntu #karmic

At this time alpha 5.2.3 is available on download link  wget http://dev.mysql.com/get/Downloads/MySQLGUITools/mysql-workbench-oss-5.2.3.tar.gz/from/http://ftp.astral.ro/mirrors/mysql.com/  


tar -zxvf mysql-workbench-oss-5.2.3.tar.gz 
cd mysql-workbench-oss-5.2.3 


sudo apt-get install libzip-dev libsigc++-2.0-dev libglade2-dev libgtkmm-2.4-dev libgnome2-dev uuid-dev lua5.1 liblua5.1-0-dev libpcre3-dev  libmysqld-dev libboost-dev python-paramiko


this time you need to install libsqlite doh ! 


sudo apt-get install libsqlite3-dev  
./autogen.sh 
make -j2 
sudo make install

5 comments:

Mathieu said...

configure: error: "BOOST library is missing"

mariuz said...

sudo apt-get install libboost1.40-dev

Mathieu said...

please add the following to your dependency list

libmysqld-dev # 1.38 was by default and worked for me...
libboost-dev
python-paramiko

mariuz said...

Thanks i have added :)

Ricardo Obregón said...

I had the same problem with ArchLinux, the solution was:
pacman -S boost